INSTALL GUIDE, PC Navigator 8 Under Ubuntu 8.04LTS/WINE

danmiddle2
Senior Member
Posts: 152
Joined: Thu Apr 03, 2008 15:51

INSTALL GUIDE, PC Navigator 8 Under Ubuntu 8.04LTS/WINE

Postby danmiddle2 » Fri Oct 10, 2008 15:06

HOW TO INSTALL
MapFactor PC Navigator 8 Under Ubuntu 8.04LTS (Hardy Heron) using WINE

First ensure you have installed WINE, to do this open up a terminal and type:

Code: Select all

sudo apt-get install wine


Next you need to insert the PC Navigator 8 CD and mount the drive:

Code: Select all

sudo mount /dev/scd0 /media/cdrom0


Then navigate to where the disc is mounted:

Code: Select all

cd /media/cdrom0

and execute;

Code: Select all

wine ./setup.exe


This should bring up a series of setup dialogue boxes with which to install the “Navigator 8 – Setup Utility” in much the same way as you'd experience on a Windows machine. I encountered no problems on my machine during this phase, so please just follow the on-screen prompts and install as per your personal requirements.

Once that is complete you should be presented with this window:
Image

From here you need to click on “Install PC Navigator”. Again; this operates as expected and no special tweaking or configuration is required. When you get to the end, this window is displayed and you should not select the box to “run PC Navigator”; this caused minor issues on both systems that I tested it on. Just exit setup – you can launch the application in a moment.

Image

That's it, the installation phase is complete. You can now exit from the MapFactor setup program, unless you wish to install the Map Explorer application, which again works as expected.

You should now find that you have an icon to launch PC Navigator has been placed under Applications>Wine>Programs>Navigator 8>PC Navigator>PC Navigator.

It is safe to launch this now to see the application, although at this stage the GPS is not setup for Navigator to recognise.

When I first loaded the application, this is the screen that I was presented with:
Image
As you can see the icons are blank and the menu button (in the middle at the top) has no writing on it. If you also suffer from this then the issue is to do with the colour depth of the display. In my case if I set the display depth to 32bit or 24bit then I get this issue. If I set it to 16bit, however, the problem goes away.

If you experience the same problem, then please do the following;

Code: Select all

sudo nano /etc/X11/xorg.conf

(or any other text editor such as gedit, if you prefer instead of nano)

and change the “DefaultDepth” variable under the relevant “Section “Screen”” title from whatever it is (normally either 24 or 32) to 16;
Save, exit and reboot (or restart your X-windows session).

Code: Select all

Section "Screen"
   Identifier           "Internal Screen"
   Device      "Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller"
   Monitor      "Internal Monitor"
   DefaultDepth   16
        SubSection       "Display"
EndSection


Once you have rebooted; re-launch PC Navigator and you should now be presented with a full compliment of text and icons like this:

Image

Now we have to get it working with the GPS device. In order to do this we need to create a virtual COM device within wine. Please bear in mind that each GPS device may be slightly different to this, but you should be able to use what I've done as a basis for getting yours working. Mine is a ZyCast USB GPS receiver.

Under your users home folder you need to cd into .wine/dosdevices (fullpath /home/username/.wine/dosdevices). Then create a static entry for a COM port. I chose to use COM5;

Code: Select all

cd ~/.wine/dosdevices
ln -s /dev/ttyUSB0 com5


Now when you load PC Navigator you should be able to set it up to use your GPS Device on COM 5. For me; the automatic configuration that PC Navigator has seems to miss the device when it scans, so a manual configuration was necessary.

From the main screen tap the “menu” button; then scroll along until you see “settings” and click that. Then select “GPS” and “Configuration”.

Click “next” to change the settings, followed by “GPS Device Only”. From here you could try the automatic configuration, but for me this failed so I selected “I want to setup the device manually”

Then select the relevant COM port, COM5 in my case, but whatever you configured it as under dosdevices.
Image

Then select the baud rate, for me this was 4800.
Image
You should then be presented with the following screen:
Image
If you see this screen then it means that the software can talk to the device. The Longitude and Latitude etc aren't populated on my screenshot because I am writing this guide indoors, but it does work.

That's it – you are now ready to Navigate where you want! Enjoy.
Attachments
Screenshot-PC_Navigator.exe 41.jpg
Screenshot-PC_Navigator.exe 39.jpg
Screenshot-Navigator 31.jpg
Screenshot-Navigator 28.jpg
Screenshot-Setup - PC Navigator 8 23.jpg
Screenshot-MapFactor Installer 12.jpg

AdrianAldermar
Junior Member
Posts: 1
Joined: Fri Mar 20, 2009 09:08

INSTALL GUIDE, PC Navigator 8 Under Ubuntu 8.04LTS/WINE

Postby AdrianAldermar » Fri Mar 20, 2009 09:10

hi,
This should bring up a series of setup dialogue boxes with which to install the “Navigator 8 – Setup Utility” in much the same way as you'd experience on a Windows machine. I encountered no problems on my machine during this phase, so please just follow the on-screen prompts and install as per your personal requirements.

Image

ErikBam1
Junior Member
Posts: 1
Joined: Sat Mar 21, 2009 07:40

INSTALL GUIDE, PC Navigator 8 Under Ubuntu 8.04LTS/WINE

Postby ErikBam1 » Sat Mar 21, 2009 07:42

hi,
good for you, guys.

I am awaiting eagerly for the pics and you reviews.

Image

danmiddle2
Senior Member
Posts: 152
Joined: Thu Apr 03, 2008 15:51

Postby danmiddle2 » Sat Mar 21, 2009 10:18


atunoa
Junior Member
Posts: 1
Joined: Sun Aug 14, 2011 17:52

Postby atunoa » Mon Aug 15, 2011 20:34

Excellent, it was one of the program that i don't want to loose on Linux. Thanks for this helfull guidance.


Return to “Linux OS”

Who is online

Users browsing this forum: No registered users and 2 guests