Sleepless nights in the name of perfection

Senior Member
Posts: 63
Joined: Mon Mar 07, 2011 20:03

Sleepless nights in the name of perfection

Postby DogTurd » Thu May 12, 2011 08:26

Everything is possible on computers, its just a question if someone has done it already or tried to already to point you in the right direction, a bit of luck (ok lots of luck), trial and error, printer for research print outs and some determination.

Base System, 3 x Ubuntu 10.10 installs within VMfusion on my MAC OSX 10.6 for various testing and configuration including snapshots and rollbacks (lots of them!). BackTrack 5 also on VMFusion x 2 installs.

What am I trying to achieve?
Port over my XP Cisco and network tools to work within Wine (Windows emulator on Linux). Get BackTrack 5 tools to work within Ubuntu so I don't have to dual boot and that I have all my tools on one operating system. Tried to run BT5 within VirtualBox on Ubuntu not enough disk space and also issue with Startup No Frame buffer option not available on menu so I could load and then run Still looking into this issue - will advise once I know more and why?

3 sleepless nights, 3 days off work (I work part-time in IT lifestyle change), lots of hours, tweaking, researching on google and I have achieved the following.......

A fully functional UX1XN running Ubuntu 10.10 with Windows based network tools and associated apps, most of the BackTrack tools I need to run. Basically a mobile handheld penetration, security and network device all in one.

How to install WineTricks

How to get Cisco SDM working in Ubuntu on Wine

How to move home directory on Ubuntu from one partition to another

How to get Microsoft Office 2007 working in Ubuntu

How to add Wine 1.3 repository

How to add BackTrack repository

The following windows software works within Wine on Ubuntu 10.10
Solarwinds Engineers Tool Set (Had to spend about 3 hours ticking off various DLL and OCX files to install via WineTricks and MDAC 2.8 Most of the Utilities work)
Boson Ciso Get Pass - encryption password decryptor (fully working)
Cisco SDM via firefox (fully working)
Microsoft Visio 2007 - partially working (hit and miss)
Cisco TFTP Server - had to enable and start TFTP service within Ubuntu (fully working)

Plus full operation and install of BackTrack tools working in Ubuntu 10.10*

* Still trying to find the repository for BT5, as it seems to have some tools missing - but everything I need is there.

What have I learnt?
1, The 32Gb SSD drive on the UX1XN just isn't big enough. Upgrade on the way as mentioned on previous threads. Even with deleting the 11Gb XP partition and remounting this as the new home folder within Ubuntu it soon filled up.
2, Minimum install size for BackTrack5 is 8Gb, impossible to mount within VirtualBox on a 32Gb drive and leave enough space for everything else, hence adding to exisiting Ubuntu menu structure.
3, The Wine Emulator has definitely improved and is more flexible in operation. Had to download the 1.3 beta version in conjunction with WineTricks and got most windows based software to run smoothly that I wanted to work.

Credit to all the people out there on the Net who submitted articles, forums. I simply found the info and tweaked it to my needs and requirements. Its turned my UX from a good device to a mind blowing device. I have all my network, security and pen testing tools on one operating system now.

Whats next? Well don't know about you but I'm going to have a cup of tea :)

Senior Member
Posts: 1603
Joined: Thu Jul 29, 2010 21:07

Postby bigs » Thu May 12, 2011 10:33

good work here dogturd. Good that you kept with ubuntu, and found the real potential for the ux! excellent links to for anyone wanting to run more windows applications in linux.

Glad you went full ubuntu, its definitely worth it and suits the limited 1gb ram limit on the ux.

congrats again
micropc hardware: sony ux17gp with 390N mainboard with Anh u7700 upgrade core2duo 1.33ghz 1024mb (now upgraded to 64gb SLC SSD Samsung), Intel 4965 agn wireless, upgrade addon 3rd mini aerial, UX37GBN blue housing incorporating improved keyboard
OS: Linux Ubuntu 10.04 lucid & now 12.04 Precise Pangolin!
sony 380N stock 1.33ghz, 1gb ram, and 40gb rotational drive OS: windows ultimate
light slim notebook: toshiba r200 1.3ghz 1.2gb ram 64gb photofast v1 ssd oS: linux ubuntu 7.04 feisty fawn

Senior Member
Posts: 63
Joined: Mon Mar 07, 2011 20:03

Postby DogTurd » Thu May 12, 2011 12:14

Thanks mate - yep lots of fun to be had. I am really enjoying Ubuntu it has so much to offer. I'm just at the start of a long journey.
The UX is really suited for Ubuntu thats for sure.

Senior Member
Posts: 63
Joined: Mon Mar 07, 2011 20:03

Postby DogTurd » Sat May 14, 2011 09:34

Still so much more to be done! Was using ICal on my Mac to sync with my Iphone4 - but I wanted something on my UX as well that could sync to everything if and when I make or delete entries.
The solution was to create a Google Calendar and use cloud based distribution.
1, Set it up on my Mac, move original entries from ICal home Calendar to Google Calendar, set Google Cal as default on Mac.
2, Setup Google Cal on my Iphone.
3, Download Mozzilla Lightening (Sunbird replacement) on my UX as an add-on to Thunderbird (my mail client on Ubuntu. Setup the link to Google Cal and set Google Cal as default.
4, Test all 3 application for Sync and entries.

Tested creation on UX to Google Cal
Tested creation on Mac to Google Cal
Tested creation on Iphone to Google Cal
Tested creation on Google Cal to all 3 devices
Includes reminders as alarm module all confirmed working.

I now have my Calendar that can be used across all 3 devices and sync's straight away if I make any changes.

I also use Wunderlist on my Iphone + Mac for task creation and ToDo lists. At the moment there isn't currently a Linux version of this. So I installed it via Wine, it runs but alot of the tabs are greyed out or missing, it dosen't sync. So I need to trail the forums for this one and see what I can sort out. It would be nice to get this one working.

How to install Wunderlist on Wine
Still dosen't work for me - may have to wait for the linux version to come out.

Senior Member
Posts: 63
Joined: Mon Mar 07, 2011 20:03

Postby DogTurd » Sat May 14, 2011 10:27

Footnote: Regarding Cisco TFTP server under Wine.
Its playing up big style and having real problems TFTP from Cisco Router/Switch to my UX. So I deleted it under Wine. Installed TFTPgui which is an TFTP app wrote for Linux.

Installed the Tkinter-writing TK applications with Python. Run python and I now have a stable working TFTP server on the UX.

Sorry almost forgot - add to TFTPgui as an application on your menu structure so that you don't have to keep opening a terminal window - add the following command
sudo python /tmp/tftpgui/ Obviously change path to where you have installed the TFTPgui folder etc. Also make sure you have read/write permissions to TFTP root + TFTP log files.

Return to “Linux OS”

Who is online

Users browsing this forum: No registered users and 2 guests