UX17GP speaker does not work, but headphone is work fine

verysmall
Junior Member
Posts: 6
Joined: Wed Nov 10, 2010 15:40

UX17GP speaker does not work, but headphone is work fine

Postby verysmall » Tue Aug 09, 2011 09:35

in ubuntu 9.04 the volume control panel has a control named "nano", when i turn on this control the speaker works.

but when i use other linux (include upgrade to higher ubuntu), i can not find the "nano" control, and the speaker is not work. but the headphone is work as normal.

i was add "options snd-hda-intel model=auto" into /etc/modprobe.d/alsa-base.conf, but is not work too.

who can help me ? please~~~~~~ thanks~~~~~~:)

verysmall
Junior Member
Posts: 6
Joined: Wed Nov 10, 2010 15:40

i sloved it by myself

Postby verysmall » Tue Aug 09, 2011 10:50

1.

Code: Select all

sudo gedit /etc/modprobe.d/alsa-base.conf


2. add:

Code: Select all

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel enable=1 index=0 model=basic

model must be "basic"!!!!

3. reboot

4. open volume control panel , and this is a "mono" control over there.
select it and unmute it.

5. play a music

6. Done!!!!!!!!!

7. sorry about my english:)

verysmall
Junior Member
Posts: 6
Joined: Wed Nov 10, 2010 15:40

there is a bug....

Postby verysmall » Wed Aug 10, 2011 07:43

there is a bug......

when i use "model=basic", speaker, micphone, headset, are work, but headset micphone is not work........
when i use "model=auto", micphone, headset and headset micphone are work, but the speaker is not work..........

i am still working on it. hoping for somebody's help me! :)

bigs
Senior Member
Posts: 1603
Joined: Thu Jul 29, 2010 21:07

Postby bigs » Wed Aug 10, 2011 21:02

verysmall, suspect either something is corrupt and not installed properly. Have you tried doing a fresh install of ubuntu 10?

On my ubuntu, the mic in, headphone out, speaker and built in speaker works. From the start the speaker did not work, until I did the alsa mod

"You need to modify the /etc/modprobe.d/alsa-base file
Open a terminal and type:
sudo gedit /etc/modprobe.d/alsa-base.conf


Add this line to the bottom of the file:
options snd-hda-intel model=auto

Save and close the file. Reboot.

If not already installed, install alsamixer.
sudo apt-get install gnome-alsamixer"
micropc hardware: sony ux17gp with 390N mainboard with Anh u7700 upgrade core2duo 1.33ghz 1024mb (now upgraded to 64gb SLC SSD Samsung), Intel 4965 agn wireless, upgrade addon 3rd mini aerial, UX37GBN blue housing incorporating improved keyboard
OS: Linux Ubuntu 10.04 lucid & now 12.04 Precise Pangolin!
sony 380N stock 1.33ghz, 1gb ram, and 40gb rotational drive OS: windows ultimate
light slim notebook: toshiba r200 1.3ghz 1.2gb ram 64gb photofast v1 ssd oS: linux ubuntu 7.04 feisty fawn


Return to “Linux OS”

Who is online

Users browsing this forum: No registered users and 3 guests